£154.79
Jetzt kaufen
Crusader Kings II: Royal Collection

Crusader Kings II: Royal Collection WindowsMac OSLinuxSteam

Crusader Kings II: Royal Collection includes the Base Game, ALL Expansions ever released.
Kategorie: RPG | Altersgrenze: 0+ | Herausgeber: Paradox Interactive AB | Entwickler: Paradox Development Studio | Veröffentlichungsdatum: 18.12.2018
Spielbeschreibung

NOTICE: Steam account required for game activation and installation

About the Game:

Crusader Kings II: Royal Collection includes the Base Game, ALL Expansions ever released.

Crusader Kings II: Royal Collection contains:

    • Crusader Kings II (Base Game)
    • Crusader Kings II Sword of Islam
    • Crusader Kings II: Legacy of Rome
    • Crusader Kings II: Sunset Invasion
    • Crusader Kings II The Republic
    • Crusader Kings II: The Old Gods
    • Crusader Kings II: Sons of Abraham
    • Crusader Kings II: Rajas of India
    • Crusader Kings II: Charlemagne
    • Crusader Kings II: Way of Life
    • Crusader Kings II: Horse Lords
    • Crusader Kings II: Conclave
    • Crusader Kings II: The Reaper's Due
    • Crusader Kings II: Monks and Mystics
    • Crusader Kings II: Jade Dragon
    • Crusader Kings II: Holy Fury

PC System Requirements
MINIMUM:
OS: Windows 7
Processor: Intel® Pentium® IV 2.4 GHz or AMD 3500+
Memory: 2 GB RAM
Hard Disk Space: 2 GB
Video Card: NVIDIA® GeForce 8800 or ATI Radeon® X1900, 512mb graphics memory required.
DirectX®: 9.0c
Sound: Direct X-compatible sound card
Additional: 3-button mouse and keyboard

Mac System Requirements
MINIMUM:
OS: Mac OS X 10.6.8 or later
Processor: Intel Core Duo Processor (2GHz or better)
Memory: 2 GB RAM
Hard Disk Space: 2 GB
Video Card: ATI Radeon HD 6750 / NVIDIA GeForce 320 / NVIDIA GeForce 9600 or higher, 1024MB graphics memory required

Linux System Requirements
MINIMUM:
OS: Ubuntu 12.04 LTS
Processor: IntelR PentiumR IV 2.4 GHz or AMD 3500+
Memory: 2 GB
Hard disk space: 2 Gb
Video Card: ATI Radeon HD 6750 / NVIDIA GeForce 320 / NVIDIA GeForce 9600 or higher, 1024MB graphics memory required.